WhatsApp us

Implement MP-BGP – ILM

Lab – Implement MP-BGP (Instructor Version)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Part 1: Topology #

Part 2: Addressing Table #

Device Interface IPv4 Address IPv6 Address IPv6 Link-Local
R1 G0/0/0 10.1.2.1/24 2001:db8:acad:1012::1/64 fe80::1:1
R1 S0/1/0 10.1.3.1/25 2001:db8:acad:1013::1/64 fe80::1:2
R1 S0/1/1 10.1.3.129/25 2001:db8:acad:1014::1/64 fe80::1:3
R1 Loopback0 192.168.1.1/27 2001:db8:acad:1000::1/64 fe80::1:4
R1 Loopback1 192.168.1.65/26 2001:db8:acad:1001::1/64 fe80::1:5
R2 G0/0/0 10.1.2.2/24 2001:db8:acad:1012::2/64 fe80::2:1
R2 G0/0/1 10.2.3.2/24 2001:db8:acad:1023::2/64 fe80::2:2
R2 Loopback0 192.168.2.1/27 2001:db8:acad:2000::1/64 fe80::2:3
R2 Loopback1 192.168.2.65/26 2001:db8:acad:2001::1/64 fe80::2:4
R3 G0/0/0 10.2.3.3/24 2001:db8:acad:1023::3/64 fe80::3:1
R3 S0/1/0 10.1.3.3/25 2001:db8:acad:1013::3/64 fe80::3:2
R3 S0/1/1 10.1.3.130/25 2001:db8:acad:1014::3/64 fe80::3:3
R3 Loopback0 192.168.3.1/27 2001:db8:acad:3000::1/64 fe80::3:4
R3 Loopback1 192.168.3.65/26 2001:db8:acad:3001::1/64 fe80::3:5

Part 3: Objectives #

Part 1: Build the Network and Configure Basic Device Settings and Interface Addressing

Part 2: Configure MP-BGP on all Routers

Part 3: Verify MP-BGP

Part 4: Configure and Verify IPv6 Summarization

Part 4: Background / Scenario #

In this lab, you will configure MP-BGP, BGP for IPv4 and IPv6 using address families.

Note: This lab is an exercise in developing, deploying, and verifying various path manipulation tools for BGP, and does not reflect networking best practices.

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs.

Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Part 5: Required Resources #

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (Choice of operating system with a terminal emulation program installed)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Part 6: Instructions #

Task 1: Build the Network and Configure Basic Device Settings and Interface Addressing #

In Part 1, you will set up the network topology and configure basic settings and interface addressing on routers.

Step 1: Cable the network as shown in the topology. #

Attach the devices as shown in the topology diagram, and cable as necessary.

Step 2: Configure basic settings for each router. #

  1. Console into each router, enter global configuration mode, and apply the basic settings and interface addressing. A command list for each router is listed below to perform initial configuration.

Open configuration window

Router R1

hostname R1

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

interface Loopback0

ip address 192.168.1.1 255.255.255.224

ipv6 address FE80::1:4 link-local

ipv6 address 2001:DB8:ACAD:1000::1/64

no shut

interface Loopback1

ip address 192.168.1.65 255.255.255.192

ipv6 address FE80::1:5 link-local

ipv6 address 2001:DB8:ACAD:1001::1/64

no shut

interface GigabitEthernet0/0/0

ip address 10.1.2.1 255.255.255.0

ipv6 address FE80::1:1 link-local

ipv6 address 2001:DB8:ACAD:1012::1/64

no shut

interface Serial0/1/0

ip address 10.1.3.1 255.255.255.128

ipv6 address FE80::1:2 link-local

ipv6 address 2001:DB8:ACAD:1013::1/64

no shut

interface Serial0/1/1

ip address 10.1.3.129 255.255.255.128

ipv6 address FE80::1:3 link-local

ipv6 address 2001:DB8:ACAD:1014::1/64

no shut

Router R2

hostname R2

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

interface Loopback0

ip address 192.168.2.1 255.255.255.224

ipv6 address FE80::2:3 link-local

ipv6 address 2001:DB8:ACAD:2000::1/64

no shut

interface Loopback1

ip address 192.168.2.65 255.255.255.192

ipv6 address FE80::2:4 link-local

ipv6 address 2001:DB8:ACAD:2001::1/64

no shut

interface GigabitEthernet0/0/0

ip address 10.1.2.2 255.255.255.0

ipv6 address FE80::2:1 link-local

ipv6 address 2001:DB8:ACAD:1012::2/64

no shut

interface GigabitEthernet0/0/1

ip address 10.2.3.2 255.255.255.0

ipv6 address FE80::2:2 link-local

ipv6 address 2001:DB8:ACAD:1023::2/64

no shut

Router R3

hostname R3

no ip domain lookup

line con 0

logging sync

exec-time 0 0

exit

interface Loopback0

ip address 192.168.3.1 255.255.255.224

ipv6 address FE80::3:4 link-local

ipv6 address 2001:DB8:ACAD:3000::1/64

no shut

interface Loopback1

ip address 192.168.3.65 255.255.255.192

ipv6 address FE80::3:5 link-local

ipv6 address 2001:DB8:ACAD:3001::1/64

no shut

interface GigabitEthernet0/0/0

ip address 10.2.3.3 255.255.255.0

negotiation auto

ipv6 address FE80::3:1 link-local

ipv6 address 2001:DB8:ACAD:1023::3/64

no shut

interface Serial0/1/0

ip address 10.1.3.3 255.255.255.128

ipv6 address FE80::3:2 link-local

ipv6 address 2001:DB8:ACAD:1013::3/64

no shut

interface Serial0/1/1

ip address 10.1.3.130 255.255.255.128

ipv6 address FE80::3:3 link-local

ipv6 address 2001:DB8:ACAD:1014::3/64

no shut

  1. Save the running configuration to startup-config.

Close configuration window

Task 2: Configure MP-BGP on all Routers #

Step 1: Implement eBGP and neighbor relationships on R1 for IPv4 and IPv6. #

  1. Enable IPv6 routing.

Open configuration window

R1(config)# ipv6 unicast-routing

  1. Enter BGP configuration mode from global configuration mode, specifying AS 1000 and configure the router ID.

R1(config)# router bgp 1000

R1(config-router)# bgp router-id 1.1.1.1

  1. Based on the topology diagram, configure all the designated IPv4 neighbors for R1.

R1(config-router)# neighbor 10.1.2.2 remote-as 500

R1(config-router)# neighbor 10.1.3.3 remote-as 300

R1(config-router)# neighbor 10.1.3.130 remote-as 300

  1. Based on the topology diagram, configure all the designated IPv6 neighbors for R1.

R1(config-router)# neighbor 2001:db8:acad:1012::2 remote-as 500

R1(config-router)# neighbor 2001:db8:acad:1013::3 remote-as 300

R1(config-router)# neighbor 2001:db8:acad:1014::3 remote-as 300

  1. Enter address family configuration mode for IPv4 and activate each of the IPv4 neighbors.

R1(config-router)# address-family ipv4 unicast

R1(config-router-af)# neighbor 10.1.2.2 activate

R1(config-router-af)# neighbor 10.1.3.3 activate

R1(config-router-af)# neighbor 10.1.3.130 activate

R1(config-router-af)# exit

  1. Enter address family configuration mode for IPv6 and activate each of the IPv6 neighbors.

R1(config-router)# address-family ipv6 unicast

R1(config-router-af)# neighbor 2001:db8:acad:1012::2 activate

R1(config-router-af)# neighbor 2001:db8:acad:1013::3 activate

R1(config-router-af)# neighbor 2001:db8:acad:1014::3 activate

R1(config-router-af)# exit

Close configuration window

Step 2: Implement eBGP and neighbor relationships on R2 for IPv4 and IPv6. #

  1. Enable IPv6 routing.

Open configuration window

R2(config)# ipv6 unicast-routing

  1. Enter BGP configuration mode from global configuration mode, specifying AS 500 and configure the router ID.

R2(config)# router bgp 500

R2(config-router)# bgp router-id 2.2.2.2

  1. Based on the topology diagram, configure all the designated IPv4 neighbors for R1.

R2(config-router)# neighbor 10.1.2.1 remote-as 1000

R2(config-router)# neighbor 10.2.3.3 remote-as 300

  1. Based on the topology diagram, configure all the designated IPv6 neighbors for R1.

R2(config-router)# neighbor 2001:db8:acad:1012::1 remote-as 1000

R2(config-router)# neighbor 2001:db8:acad:1023::3 remote-as 300

  1. Enter address family configuration mode for IPv4 and activate each of the IPv4 neighbors.

R2(config-router)# address-family ipv4 unicast

R2(config-router-af)# neighbor 10.1.2.1 activate

R2(config-router-af)# neighbor 10.2.3.3 activate

R2(config-router-af)# exit

  1. Enter address family configuration mode for IPv6 and activate each of the IPv6 neighbors.

R2(config-router)# address-family ipv6 unicast

R2(config-router-af)# neighbor 2001:db8:acad:1012::1 activate

R2(config-router-af)# neighbor 2001:db8:acad:1023::3 activate

R2(config-router-af)# exit

Close configuration window

Step 3: Implement eBGP and neighbor relationships on R3 for IPv4 and IPv6. #

  1. Enable IPv6 routing.

Open configuration window

R3(config)# ipv6 unicast-routing

  1. Enter BGP configuration mode from global configuration mode, specifying AS 300 and configure the router ID.

R3(config)# router bgp 300

R3(config-router)# bgp router-id 3.3.3.3

  1. Based on the topology diagram, configure all the designated IPv4 neighbors for R1.

R3(config-router)# neighbor 10.2.3.2 remote-as 500

R3(config-router)# neighbor 10.1.3.1 remote-as 1000

R3(config-router)# neighbor 10.1.3.129 remote-as 1000

  1. Based on the topology diagram, configure all the designated IPv6 neighbors for R1.

R3(config-router)# neighbor 2001:db8:acad:1023::2 remote-as 500

R3(config-router)# neighbor 2001:db8:acad:1013::1 remote-as 1000

R3(config-router)# neighbor 2001:db8:acad:1014::1 remote-as 1000

  1. Enter address family configuration mode for IPv4 and activate each of the IPv4 neighbors.

R3(config-router)# address-family ipv4 unicast

R3(config-router-af)# neighbor 10.1.3.1 activate

R3(config-router-af)# neighbor 10.1.3.129 activate

R3(config-router-af)# neighbor 10.2.3.2 activate

R3(config-router-af)# exit

  1. Enter address family configuration mode for IPv6 and activate each of the IPv6 neighbors.

R3(config-router)# address-family ipv6 unicast

R3(config-router-af)# neighbor 2001:db8:acad:1023::2 activate

R3(config-router-af)# neighbor 2001:db8:acad:1013::1 activate

R3(config-router-af)# neighbor 2001:db8:acad:1014::1 activate

R3(config-router-af)# exit

Close configuration window

Step 4: Advertise IPv4 and IPv6 prefixes on R1. #

  1. Enter address family configuration mode for IPv4 and advertise the IPv4 prefixes.

Open configuration window

R1(config-router)# address-family ipv4 unicast

R1(config-router-af)# network 192.168.1.0 mask 255.255.255.224

R1(config-router-af)# network 192.168.1.64 mask 255.255.255.192

R1(config-router-af)# exit

  1. Enter address family configuration mode for IPv6 and advertise the IPv6 prefixes.

R1(config-router)# address-family ipv6 unicast

R1(config-router-af)# network 2001:db8:acad:1000::/64

R1(config-router-af)# network 2001:db8:acad:1001::/64

R1(config-router-af)# exit

Close configuration window

Step 5: Advertise IPv4 and IPv6 prefixes on R2. #

  1. Enter address family configuration mode for IPv4 and advertise the IPv4 prefixes.

Open configuration window

R2(config-router)# address-family ipv4 unicast

R2(config-router-af)# network 192.168.2.0 mask 255.255.255.224

R2(config-router-af)# network 192.168.2.64 mask 255.255.255.192

R2(config-router-af)# exit

  1. Enter address family configuration mode for IPv6 and advertise the IPv6 prefixes.

R2(config-router)# address-family ipv6 unicast

R2(config-router-af)# network 2001:db8:acad:2000::/64

R2(config-router-af)# network 2001:db8:acad:2001::/64

R2(config-router-af)# exit

Close configuration window

Step 6: Advertise IPv4 and IPv6 prefixes on R3. #

  1. Enter address family configuration mode for IPv4 and advertise the IPv4 prefixes.

Open configuration window

R3(config-router)# address-family ipv4 unicast

R3(config-router-af)# network 192.168.3.0 mask 255.255.255.224

R3(config-router-af)# network 192.168.3.64 mask 255.255.255.192

R3(config-router-af)# exit

  1. Enter address family configuration mode for IPv6 and advertise the IPv6 prefixes.

R3(config-router)# address-family ipv6 unicast

R3(config-router-af)# network 2001:db8:acad:3000::/64

R3(config-router-af)# network 2001:db8:acad:3001::/64

R3(config-router-af)# exit

Close configuration window

Note: Notice that the networks between the routers are not being advertised in eBGP. Typically, only the prefixes of the AS need to be advertised in eBGP. eBGP neighbors are typically directly connected and therefore will be able to form an adjacency. There is typically no need to advertise and inject the directly connected prefixes into the BGP routing table.

Task 3: Verify MP-BGP #

Step 1: Display detailed neighbor adjacency information. #

Use the show bgp all neighbors command on R2 to display detailed information about BGP connections to neighbors for all (IPv4 and IPv6) address families. Each neighbor shows that it is in the “Established” state. This indicates that the router can send and receive BGP messages. R2 has two neighbor addresses, R1 and R3, for each address family, IPv4 and IPv6.

Open configuration window

R2# show bgp all neighbors

For address family: IPv4 Unicast

BGP neighbor is 10.1.2.1,  remote AS 1000, external link

BGP version 4, remote router ID 1.1.1.1

BGP state = Established, up for 01:56:25

Last read 00:00:48, last write 00:00:50, hold time is 180, keepalive interval is 60 seconds

<output omitted>

 

BGP neighbor is 10.2.3.3,  remote AS 300, external link

BGP version 4, remote router ID 3.3.3.3

BGP state = Established, up for 01:55:47

Last read 00:00:04, last write 00:00:41, hold time is 180, keepalive interval is 60 seconds

<output omitted>

 

For address family: IPv6 Unicast

BGP neighbor is 2001:DB8:ACAD:1012::1,  remote AS 1000, external link

BGP version 4, remote router ID 1.1.1.1

BGP state = Established, up for 01:56:39

Last read 00:00:07, last write 00:00:04, hold time is 180, keepalive interval is 60 seconds

<output omitted>

 

BGP neighbor is 2001:DB8:ACAD:1023::3,  remote AS 300, external link

BGP version 4, remote router ID 3.3.3.3

BGP state = Established, up for 01:56:09

Last read 00:00:32, last write 00:00:48, hold time is 180, keepalive interval is 60 seconds

<output omitted>

Note: Most information displayed using show bgp all neighbors command has been omitted for brevity. The command show bgp neighbors is used to display only BGP for IPv4 adjacencies. To display the same information for only IPv6 neighbors, use the command show bgp ipv6 neighbors.

Questions: #

What is the BGP state for each neighbor adjacency?

Type your answers here.

Established

How often are BGP keepalives sent?

Type your answers here.

Every 60 seconds

How many seconds will a BGP session remain open if no further keepalive messages are received?

Type your answers here.

180 seconds, the value of the hold time interval

Step 2: Display summary neighbor adjacency information. #

Use the show bgp ipv4 unicast summary and show bgp ipv6 unicast summary commands on R2 to display a summary of IPv4/IPv6 peering information with R1 and R3. The information displayed using the show bgp ipv4 unicast summary is a subset of show ip all bgp command.

Open configuration window

R2# show bgp ipv4 unicast summary

BGP router identifier 2.2.2.2, local AS number 500

BGP table version is 11, main routing table version 11

6 network entries using 1488 bytes of memory

10 path entries using 1360 bytes of memory

5/3 BGP path/bestpath attribute entries using 1400 bytes of memory

4 BGP AS-PATH entries using 128 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 4376 total bytes of memory

BGP activity 12/0 prefixes, 20/0 paths, scan interval 60 secs

 

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.1.2.1        4        1000     152     151       11    0    0 02:12:36  4

10.2.3.3        4         300     150     150       11    0    0 02:11:51  4

 

R2# show bgp ipv6 unicast summary

BGP router identifier 2.2.2.2, local AS number 500

BGP table version is 9, main routing table version 9

6 network entries using 1632 bytes of memory

10 path entries using 1520 bytes of memory

5/3 BGP path/bestpath attribute entries using 1400 bytes of memory

4 BGP AS-PATH entries using 128 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 4680 total bytes of memory

BGP activity 12/0 prefixes, 20/0 paths, scan interval 60 secs

 

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

2001:DB8:ACAD:1012::1

4        1000     150     150        9    0    0 02:12:39  4

2001:DB8:ACAD:1023::3

4         300     151     150        9    0    0 02:11:54  4

Question: #

What is the difference between the “local AS number” and the “AS” number displayed in the list of BGP neighbors?

Type your answers here.

The local AS is the AS that this router belongs to. The AS in the list of BGP neighbors is the AS of the remote neighbor.

Step 3: Verify BGP tables for IPv4 and IPv6. #

  1. Use the show bgp ipv4 unicast command on R2 to display its IPv4 BGP table. This command is equivalent to the show ip bgp command and either command can be used. Notice that R1 shows six IPv4 networks in its IPv4 BGP table. Each network is valid “*” and has one path which is the best path “>”. Amongst other information, the next hop IPv4 address and the AS path are included.

R2# show bgp ipv4 unicast

BGP table version is 11, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,

r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

x best-external, a additional-path, c RIB-compressed,

t secondary path, L long-lived-stale,

Origin codes: i – IGP, e – EGP, ? – incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

Network          Next Hop            Metric LocPrf Weight Path

*    192.168.1.0/27   10.2.3.3                               0 300 1000 i

*>                    10.1.2.1                 0             0 1000 i

*    192.168.1.64/26  10.2.3.3                               0 300 1000 i

*>                    10.1.2.1                 0             0 1000 i

*>   192.168.2.0/27   0.0.0.0                  0         32768 i

*>   192.168.2.64/26  0.0.0.0                  0         32768 i

*    192.168.3.0/27   10.1.2.1                               0 1000 300 i

*>                    10.2.3.3                 0             0 300 i

*    192.168.3.64/26  10.1.2.1                               0 1000 300 i

*>                    10.2.3.3                 0             0 300 i

  1. Use the show bgp ipv6 unicast command on R2 to display similar information for its IPv6 BGP table.

R2# show bgp ipv6 unicast

BGP table version is 9, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,

r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

x best-external, a additional-path, c RIB-compressed,

t secondary path, L long-lived-stale,

Origin codes: i – IGP, e – EGP, ? – incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

Network          Next Hop            Metric LocPrf Weight Path

*    2001:DB8:ACAD:1000::/64

2001:DB8:ACAD:1023::3

0 300 1000 i

*>                   2001:DB8:ACAD:1012::1

0             0 1000 i

*    2001:DB8:ACAD:1001::/64

2001:DB8:ACAD:1023::3

0 300 1000 i

*>                   2001:DB8:ACAD:1012::1

0             0 1000 i

*>   2001:DB8:ACAD:2000::/64

::                       0         32768 i

*>   2001:DB8:ACAD:2001::/64

::                       0         32768 i

*    2001:DB8:ACAD:3000::/64

2001:DB8:ACAD:1012::1

0 1000 300 i

*>                   2001:DB8:ACAD:1023::3

0             0 300 i

*    2001:DB8:ACAD:3001::/64

2001:DB8:ACAD:1012::1

0 1000 300 i

*>                   2001:DB8:ACAD:1023::3

0             0 300 i

Questions: #

In the first output show bgp ipv4 unicast, why is 10.1.2.1 the preferred next hop address for 192.168.1.0 instead of 10.2.3.3?

Type your answers here.

Given that prior BGP path selection attributes are equal, this next hop is only one AS away, whereas 10.2.3.3 is two AS hops.

Why do some entries in the show bgp ipv6 unicast output include a next hop address of “::”?

Type your answers here.

This is unspecified address and indicates that the local router is generating the prefix for the BGP table.

Step 4: Viewing explicit routes and path attributes. #

  1. Use the show bgp ipv4 unicast ipv4-prefix subnet-mask command on R2 to display all the paths for a specific route and BGP path attributes for that route.

R2# show bgp ipv4 unicast 192.168.1.0 255.255.255.224

BGP routing table entry for 192.168.1.0/27, version 2

Paths: (2 available, best #2, table default)

Advertised to update-groups:

1

Refresh Epoch 1

300 1000

10.2.3.3 from 10.2.3.3 (3.3.3.3)

Origin IGP, localpref 100, valid, external

rx pathid: 0, tx pathid: 0

Refresh Epoch 1

1000

10.1.2.1 from 10.1.2.1 (1.1.1.1)

Origin IGP, metric 0, localpref 100, valid, external, best

rx pathid: 0, tx pathid: 0x0

The show bgp ipv6 unicast ipv6-prefix prefix-length command displays similar information for IPv6 prefixes.

R2# show bgp ipv6 unicast 2001:db8:acad:1000::/64

BGP routing table entry for 2001:DB8:ACAD:1000::/64, version 2

Paths: (2 available, best #2, table default)

Flag: 0x100

Advertised to update-groups:

1

Refresh Epoch 1

300 1000

2001:DB8:ACAD:1023::3 (FE80::3:1) from 2001:DB8:ACAD:1023::3 (3.3.3.3)

Origin IGP, localpref 100, valid, external

rx pathid: 0, tx pathid: 0

Refresh Epoch 1

1000

2001:DB8:ACAD:1012::1 (FE80::1:1) from 2001:DB8:ACAD:1012::1 (1.1.1.1)

Origin IGP, metric 0, localpref 100, valid, external, best

rx pathid: 0, tx pathid: 0x0

Question: #

Why does the output for the show bgp ipv6 unicast command include the link-local address following the global unicast address?

Type your answers here.

This is the link-local address of the router that sent the BGP update. Link-local addresses are used to send BGP messages.

  1. Use the show bgp ipv4 unicast neighbors ipv4-prefix advertised-routes command on R2 to display IPv4 routes advertised to a specific neighbor.

R2# show bgp ipv4 unicast neighbors 10.1.2.1 advertised-routes

BGP table version is 11, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,

r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

x best-external, a additional-path, c RIB-compressed,

t secondary path, L long-lived-stale,

Origin codes: i – IGP, e – EGP, ? – incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

Network          Next Hop            Metric LocPrf Weight Path

*>   192.168.1.0/27   10.1.2.1                 0             0 1000 i

*>   192.168.1.64/26  10.1.2.1                 0             0 1000 i

*>   192.168.2.0/27   0.0.0.0                  0         32768 i

*>   192.168.2.64/26  0.0.0.0                  0         32768 i

*>   192.168.3.0/27   10.2.3.3                 0             0 300 i

*>   192.168.3.64/26  10.2.3.3                 0             0 300 i

 

Total number of prefixes 6

  1. Use the show bgp ipv6 unicast ipv5-prefix prefix-length command to display similar information for IPv6 advertised routes.

R2# show bgp ipv6 unicast neighbors 2001:db8:acad:1012::1 advertised-routes

BGP table version is 9, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,

r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

x best-external, a additional-path, c RIB-compressed,

t secondary path, L long-lived-stale,

Origin codes: i – IGP, e – EGP, ? – incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

Network          Next Hop            Metric LocPrf Weight Path

*>   2001:DB8:ACAD:1000::/64

2001:DB8:ACAD:1012::1

0             0 1000 i

*>   2001:DB8:ACAD:1001::/64

2001:DB8:ACAD:1012::1

0             0 1000 i

*>   2001:DB8:ACAD:2000::/64

::                       0         32768 i

*>   2001:DB8:ACAD:2001::/64

::                       0         32768 i

*>   2001:DB8:ACAD:3000::/64

2001:DB8:ACAD:1023::3

0             0 300 i

*>   2001:DB8:ACAD:3001::/64

2001:DB8:ACAD:1023::3

0             0 300 i

 

Total number of prefixes 6

Question: #

Why do some entries in the show bgp ipv4 unicast neighbors output include a next hop address of 0.0.0.0 and the show bgp ipv6 unicast neighbors output includes a next hop address of “::”?

Type your answers here.

This indicates that the local router is generating the prefix.

Step 5: Verifying the IP routing tables for IPv4 and IPv6. #

  1. By examining the IPv4 and IPv6 routing tables on R2, you can verify that BGP is receiving the IPv4 and IPv6 prefixes from R1 and R3.

R2# show ip route bgp | begin Gateway

Gateway of last resort is not set

 

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

B        192.168.1.0/27 [20/0] via 10.1.2.1, 04:29:03

B        192.168.1.64/26 [20/0] via 10.1.2.1, 04:28:32

192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks

B        192.168.3.0/27 [20/0] via 10.2.3.3, 04:17:14

B        192.168.3.64/26 [20/0] via 10.2.3.3, 04:16:44

 

R2# show ipv6 route bgp | section 2001

B   2001:DB8:ACAD:1000::/64 [20/0]

via FE80::1:1, GigabitEthernet0/0/0

B   2001:DB8:ACAD:1001::/64 [20/0]

via FE80::1:1, GigabitEthernet0/0/0

B   2001:DB8:ACAD:3000::/64 [20/0]

via FE80::3:1, GigabitEthernet0/0/1

B   2001:DB8:ACAD:3001::/64 [20/0]

via FE80::3:1, GigabitEthernet0/0/1

Close configuration window

Task 4: Configure and Verify IPv6 Route Summarization #

Summarizing prefixes conserves router resources and accelerates best-path calculation by reducing the size of the table. Summarization can be configured either for prefixes originated by the AS or prefixes received from downstream providers. Summarization also provides the benefits of stability by hiding flapping routes or having to install new prefixes when they are contained within a summary.

  1. Verify R2 and R3 are receiving 2001:db8:acad:1000::/64 and 2001:db8:acad:1001::/64 from R1.

Open configuration window

R2# show ipv6 route bgp | section 2001

B   2001:DB8:ACAD:1000::/64 [20/0]

via FE80::1:1, GigabitEthernet0/0/0

B   2001:DB8:ACAD:1001::/64 [20/0]

via FE80::1:1, GigabitEthernet0/0/0

B   2001:DB8:ACAD:3000::/64 [20/0]

via FE80::3:1, GigabitEthernet0/0/1

B   2001:DB8:ACAD:3001::/64 [20/0]

via FE80::3:1, GigabitEthernet0/0/1

 

R3# show ipv6 route bgp | section 2001

B   2001:DB8:ACAD:1000::/64 [20/0]

via FE80::1:2, Serial0/1/0

B   2001:DB8:ACAD:1001::/64 [20/0]

via FE80::1:2, Serial0/1/0

B   2001:DB8:ACAD:2000::/64 [20/0]

via FE80::2:2, GigabitEthernet0/0/0

B   2001:DB8:ACAD:2001::/64 [20/0]

via FE80::2:2, GigabitEthernet0/0/0

  1. Although AS 1000 only has two IPv6 prefixes – 2001:db8:acad:1000::/64 and 2001:db8:acad:1001::/64, this customer has been allocated the entire 2001:db8:acad:1000::/52 prefix (2001:db8:acad:1xxx).

R1 is configured using the aggregate-address command in IPv6 AF mode to summarize its IPv6 prefixes. This is known as a summary route or aggregate route. The summary-only option suppresses the more specific prefixes from also being advertised.

R1(config)# router bgp 1000

R1(config-router)# address-family ipv6 unicast

R1(config-router-af)# aggregate-address 2001:db8:acad:1000::/52 summary-only

  1. Verify that R2 and R3 are now receiving the aggregate route and installing it in the IPv6 BGP table.

R2# show bgp ipv6 unicast | begin Network

Network          Next Hop            Metric LocPrf Weight Path

*    2001:DB8:ACAD:1000::/52

2001:DB8:ACAD:1023::3

0 300 1000 i

*>                   2001:DB8:ACAD:1012::1

0             0 1000 i

<output omitted>

 

R3# show bgp ipv6 unicast | begin Network

Network          Next Hop            Metric LocPrf Weight Path

*    2001:DB8:ACAD:1000::/52

2001:DB8:ACAD:1023::2

0 500 1000 i

*                    2001:DB8:ACAD:1014::1

0             0 1000 i

<output omitted>

  1. Verify that R2 and R3 are now receiving the aggregate route and it is installed in the IPv6 routing table.

R2# show ipv6 route bgp | section 2001

B   2001:DB8:ACAD:1000::/52 [20/0]

via FE80::1:1, GigabitEthernet0/0/0

B   2001:DB8:ACAD:3000::/64 [20/0]

via FE80::3:1, GigabitEthernet0/0/1

B   2001:DB8:ACAD:3001::/64 [20/0]

via FE80::3:1, GigabitEthernet0/0/1

 

R3# show ipv6 route bgp | section 2001

B   2001:DB8:ACAD:1000::/52 [20/0]

via FE80::1:2, Serial0/1/0

B   2001:DB8:ACAD:2000::/64 [20/0]

via FE80::2:2, GigabitEthernet0/0/0

B   2001:DB8:ACAD:2001::/64 [20/0]

via FE80::2:2, GigabitEthernet0/0/0

Question: #

If R1’s 2001:db8:acad:1000::/64 network went down, what would be the effect, if any, on the routing tables of R2 and R3? Explain.

Type your answers here.

There would be no effect because the summary route will still be valid and advertised as long as at least one subnet within the summary route is still reachable. In this case, as long as 2001:db8:acad:1001::/64 is still reachable, this aggregated route will still be advertised.

Close configuration window

Part 7: Router Interface Summary Table #

Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
4221 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
4300 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Device Configs – Final #

Router R1 #

R1# show running-config

Building configuration…

 

 

Current configuration : 2651 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

ipv6 unicast-routing

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

mode none

!

interface Loopback0

ip address 192.168.1.1 255.255.255.224

ipv6 address FE80::1:4 link-local

ipv6 address 2001:DB8:ACAD:1000::1/64

!

interface Loopback1

ip address 192.168.1.65 255.255.255.192

ipv6 address FE80::1:5 link-local

ipv6 address 2001:DB8:ACAD:1001::1/64

!

interface GigabitEthernet0/0/0

ip address 10.1.2.1 255.255.255.0

negotiation auto

ipv6 address FE80::1:1 link-local

ipv6 address 2001:DB8:ACAD:1012::1/64

!

interface GigabitEthernet0/0/1

no ip address

negotiation auto

!

interface Serial0/1/0

ip address 10.1.3.1 255.255.255.128

ipv6 address FE80::1:2 link-local

ipv6 address 2001:DB8:ACAD:1013::1/64

!

interface Serial0/1/1

ip address 10.1.3.129 255.255.255.128

ipv6 address FE80::1:3 link-local

ipv6 address 2001:DB8:ACAD:1014::1/64

!

router bgp 1000

bgp router-id 1.1.1.1

bgp log-neighbor-changes

neighbor 10.1.2.2 remote-as 500

neighbor 10.1.3.3 remote-as 300

neighbor 10.1.3.130 remote-as 300

neighbor 2001:DB8:ACAD:1012::2 remote-as 500

neighbor 2001:DB8:ACAD:1013::3 remote-as 300

neighbor 2001:DB8:ACAD:1014::3 remote-as 300

!

address-family ipv4

network 192.168.1.0 mask 255.255.255.224

network 192.168.1.64 mask 255.255.255.192

neighbor 10.1.2.2 activate

neighbor 10.1.3.3 activate

neighbor 10.1.3.130 activate

no neighbor 2001:DB8:ACAD:1012::2 activate

no neighbor 2001:DB8:ACAD:1013::3 activate

no neighbor 2001:DB8:ACAD:1014::3 activate

exit-address-family

!

address-family ipv6

network 2001:DB8:ACAD:1000::/64

network 2001:DB8:ACAD:1001::/64

aggregate-address 2001:DB8:ACAD:1000::/52 summary-only

neighbor 2001:DB8:ACAD:1012::2 activate

neighbor 2001:DB8:ACAD:1013::3 activate

neighbor 2001:DB8:ACAD:1014::3 activate

exit-address-family

!

ip forward-protocol nd

no ip http server

ip http secure-server

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

end

Part 8: Router R2 #

R2# show running-config

Building configuration…

 

 

Current configuration : 2218 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R2

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

ipv6 unicast-routing

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

mode none

!

interface Loopback0

ip address 192.168.2.1 255.255.255.224

ipv6 address FE80::2:3 link-local

ipv6 address 2001:DB8:ACAD:2000::1/64

!

interface Loopback1

ip address 192.168.2.65 255.255.255.192

ipv6 address FE80::2:4 link-local

ipv6 address 2001:DB8:ACAD:2001::1/64

!

interface GigabitEthernet0/0/0

ip address 10.1.2.2 255.255.255.0

negotiation auto

ipv6 address FE80::2:1 link-local

ipv6 address 2001:DB8:ACAD:1012::2/64

!

interface GigabitEthernet0/0/1

ip address 10.2.3.2 255.255.255.0

negotiation auto

ipv6 address FE80::2:2 link-local

ipv6 address 2001:DB8:ACAD:1023::2/64

!

router bgp 500

bgp router-id 2.2.2.2

bgp log-neighbor-changes

neighbor 10.1.2.1 remote-as 1000

neighbor 10.2.3.3 remote-as 300

neighbor 2001:DB8:ACAD:1012::1 remote-as 1000

neighbor 2001:DB8:ACAD:1023::3 remote-as 300

!

address-family ipv4

network 192.168.2.0 mask 255.255.255.224

network 192.168.2.64 mask 255.255.255.192

neighbor 10.1.2.1 activate

neighbor 10.2.3.3 activate

no neighbor 2001:DB8:ACAD:1012::1 activate

no neighbor 2001:DB8:ACAD:1023::3 activate

exit-address-family

!

address-family ipv6

network 2001:DB8:ACAD:2000::/64

network 2001:DB8:ACAD:2001::/64

neighbor 2001:DB8:ACAD:1012::1 activate

neighbor 2001:DB8:ACAD:1023::3 activate

exit-address-family

!

ip forward-protocol nd

no ip http server

ip http secure-server

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

end

Router R3 #

R3#show running-config

Building configuration…

 

 

Current configuration : 2597 bytes

!

version 16.9

service timestamps debug datetime msec

service timestamps log datetime msec

platform qfp utilization monitor load 80

no platform punt-keepalive disable-kernel-core

!

hostname R3

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

no ip domain lookup

!

login on-success log

!

subscriber templating

!

ipv6 unicast-routing

multilink bundle-name authenticated

!

spanning-tree extend system-id

!

redundancy

mode none

!

interface Loopback0

ip address 192.168.3.1 255.255.255.224

ipv6 address FE80::3:4 link-local

ipv6 address 2001:DB8:ACAD:3000::1/64

!

interface Loopback1

ip address 192.168.3.65 255.255.255.192

ipv6 address FE80::3:5 link-local

ipv6 address 2001:DB8:ACAD:3001::1/64

!

interface GigabitEthernet0/0/0

ip address 10.2.3.3 255.255.255.0

negotiation auto

ipv6 address FE80::3:1 link-local

ipv6 address 2001:DB8:ACAD:1023::3/64

!

interface GigabitEthernet0/0/1

no ip address

negotiation auto

!

interface Serial0/1/0

ip address 10.1.3.3 255.255.255.128

ipv6 address FE80::3:2 link-local

ipv6 address 2001:DB8:ACAD:1013::3/64

!

interface Serial0/1/1

ip address 10.1.3.130 255.255.255.128

ipv6 address FE80::3:3 link-local

ipv6 address 2001:DB8:ACAD:1014::3/64

!

router bgp 300

bgp router-id 3.3.3.3

bgp log-neighbor-changes

neighbor 10.1.3.1 remote-as 1000

neighbor 10.1.3.129 remote-as 1000

neighbor 10.2.3.2 remote-as 500

neighbor 2001:DB8:ACAD:1013::1 remote-as 1000

neighbor 2001:DB8:ACAD:1014::1 remote-as 1000

neighbor 2001:DB8:ACAD:1023::2 remote-as 500

!

address-family ipv4

network 192.168.3.0 mask 255.255.255.224

network 192.168.3.64 mask 255.255.255.192

neighbor 10.1.3.1 activate

neighbor 10.1.3.129 activate

neighbor 10.2.3.2 activate

no neighbor 2001:DB8:ACAD:1013::1 activate

no neighbor 2001:DB8:ACAD:1014::1 activate

no neighbor 2001:DB8:ACAD:1023::2 activate

exit-address-family

!

address-family ipv6

network 2001:DB8:ACAD:3000::/64

network 2001:DB8:ACAD:3001::/64

neighbor 2001:DB8:ACAD:1013::1 activate

neighbor 2001:DB8:ACAD:1014::1 activate

neighbor 2001:DB8:ACAD:1023::2 activate

exit-address-family

!

ip forward-protocol nd

no ip http server

ip http secure-server

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

end

Updated on September 28, 2024

Frequently Asked Questions

Ebooks FAQ

  • May I share my eBooks with others?

    You can share Ebooks with anyone

  • What is an eBook?
    1. eBooks are digital, downloadable versions of books. In most cases, they look exactly like the print versions with the same graphs, charts, and illustrations.
    2. You can download and read eBooks on your desktop, laptop, and mobile devices with the free Reader application.
  • Do I need special software or hardware to read eBooks?

    All you need is your PC, laptop or hand held device and the free Reader software. We offer eBooks in three different formats: PDF download, EPUB download and Online Reader.  Our Online Reader requires no software other than an internet browser. For downloading, we will provide you with a link to download the appropriate Reader software free of charge when you make a our member. 

  • I have a questions

    If you have any questions including file download or Ebooks name errors, copyright etc, please contact us

  • How to downloan ebooks?

    Immediately. Once you complete you register a member account first and download it free 

  • what’s Ebooks files format ?

    our eBooks as EPUB, CHM and PDF files. 

    To read EPUB files, you can download the latest version of the free Adobe Digital Editions here.

    To read PDF files, you can download the latest version of the free Adobe Acrobat Reader here. 

    Notes:some files need unzip,you can read it

  • I can’t find the some ebooks?

    If you need any Ebooks, please contact us.

Shopping cart
Sign in

No account yet?

Privacy and cookies

If you continue to use our website, Please confirm that you allow the use of cookies.Privacy Preference Center and Privacy Policy
Please select your product
Shop
0 Wishlist
0 items Cart
My account