How to combine multiple physical connections into a single logical link? what is PPP Multilink, Layer 2 etherchannel and Layer 3 Port channel?

Table of contents

While all three terms involve combining multiple physical connections into a single logical link, the key difference lies in the network layer they operate on: PPP multilink functions at Layer 2, while a Layer 2 EtherChannel operates within a switch at Layer 2, and a Layer 3 EtherChannel operates at Layer 3 on a router; essentially, PPP multilink is primarily used for WAN connections, while EtherChannels are typically implemented on LANs between switches or a switch and a router depending on the layer involved.

Multilink PPP allows us to combine physical serial links into a single logical or MLP bundle. MLP is used to aggregate multiple WAN links into one logical channel for the transportation of traffic from one router to another, MLP enables the load—balancing of traffic from different links as well and allows some level of redundancy in case of line failure on a single link.MLP Supports a maximum of ten member links per bundle or single logical link.

Ether-channel or (link aggregation). Ether-channel is a technology that allows us to bundle multiple physical links into a single logical link. Ether-channel is used to aggregate bandwidth between multiple layer 2 / layer 3 interfaces. Ether-channel increases bandwidth and provides redundancy by aggregating individual links between switches. Ether-channel load balances traffic over all the links in the bundle. We can use a maximum of 8 physical interfaces to configure the bundle into a single logical link.

when we configure an EtherChannel there are two protocols we can choose from:

 

  • PAgP (Cisco proprietary)
  • LACP (IEEE standard)

LAYER 3 EtherChannel technology allows us to bundle multiple physical links into one logical link. It is used to increase the bandwidth and provide redundancy between multiple layer 2 / layer 3 interfaces. Layer 2 EtherChannel operates on the data link layer, but layer 3 EtherChannel operates at the network layer, allowing it to route traffic.  Ether-channel load balances traffic over all the links in the bundle. We can use a maximum 8 physical interfaces to configure the bundle into a single logical link.

Note:- when we configure the port channel (layer 3) we must configure the No switchport command before using the command port channel. if we do not configure the no switchport command. the port channel will be the default layer 2 channel and we can not change it. To avoid this, configure the no switchport command.

(let’s see the configuration of  PPP Multilink, Layer 2 EtherChannel, and Layer 3 Port channel starting will PPP Multilink)

  • configure single logical link, group number 1
  • configure channel ip address 192.168.1.0/24

R1(config)#interface serial 4/0
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/1
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/2
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/3
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/4
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/5
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/6
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 4/7
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface multilink 1
R1(config-if)#ppp multilink group 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit

R1(config)#do show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Serial4/0                  unassigned      YES manual up                    up
Serial4/1                  unassigned      YES manual up                    up
Serial4/2                  unassigned      YES manual up                    up
Serial4/3                  unassigned      YES manual up                    up
Serial4/4                  unassigned      YES manual up                    up
Serial4/5                  unassigned      YES manual up                    up
Serial4/6                  unassigned      YES manual up                    up
Serial4/7                  unassigned      YES manual up                    up
Multilink1                 192.168.1.1     YES manual up                    up

R1(config)#router eigrp 100

R1(config-router)#network 10.0.0.0

R1(config-router)#network 192.168.1.0

R1(config-router)#no auto-summary

R1(config-router)#exit

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 10.1.1.1 255.0.0.0

R1(config-if)#no keepalive

R1(config-if)#no shutdown

R1(config-if)#exit

R2(config)#interface multilink 1

R2(config-if)#ppp multilink group 1

R2(config-if)#ip address 192.168.1.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

*Jan 24 12:32:07.535: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1 , changed state to down

R2(config)#interface serial 4/0

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/1

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/2

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/3

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/4

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/5

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/6

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface serial 4/7

R2(config-if)#no ip address

R2(config-if)#encapsulation ppp

R2(config-if)#ppp multilink

R2(config-if)#ppp multilink group 1

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#do show ip int br

Interface                  IP-Address      OK? Method Status                Protocol

Serial4/0                  unassigned      YES manual up                    up

Serial4/1                  unassigned      YES manual up                    up

Serial4/2                  unassigned      YES manual up                    up

Serial4/3                  unassigned      YES manual up                    up

Serial4/4                  unassigned      YES manual up                    up

Serial4/5                  unassigned      YES manual up                    up

Serial4/6                  unassigned      YES manual up                    up

Serial4/7                  unassigned      YES manual up                    up

Multilink1                 192.168.1.2     YES manual up                    up

R2(config)#router eigrp 100

R2(config-router)#network 20.0.0.0

R2(config-router)#network 192.168.1.0

R2(config-router)#no auto-summary

R2(config-router)#exit

*Jan 24 12:36:18.531: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.1 (Multilink1) is up: new adjacencya

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 20.1.1.1 255.0.0.0

R2(config-if)#no keepalive

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#do trace 10.1.1.1 source 20.1.1.1

Type escape sequence to abort.

Tracing the route to 10.1.1.1

1 192.168.1.1 20 msec 28 msec 32 msec

R1(config)#do show run interface multilink 1

Building configuration…

Current configuration : 104 bytes

!

interface Multilink1

ip address 192.168.1.1 255.255.255.0

ppp multilink

ppp multilink group 1

end

R1(config)#do show interface multilink 1

Multilink1 is up, line protocol is up

Hardware is multilink group interface

Internet address is 192.168.1.1/24

MTU 1500 bytes, BW 12352 Kbit, DLY 100000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open, multilink Open

Open: IPCP, CDPCP, loopback not set

Keepalive set (10 sec)

 

R1(config)#do show interface multilink 1 | include line protocol

Multilink1 is up, line protocol is up

R1(config)#do show ppp multilink

Multilink1, bundle name is R2

Endpoint discriminator is R2

Bundle up for 00:05:45, total bandwidth 12352, load 1/255

Receive buffer limit 96000 bytes, frag timeout 1000 ms

0/0 fragments/bytes in reassembly list

0 lost fragments, 15 reordered

0/0 discarded fragments/bytes, 0 lost received

0x49 received sequence, 0x54 sent sequence

Member links: 8 active, 0 inactive (max not set, min not set)

Se4/4, since 00:05:45

Se4/0, since 00:05:45

Se4/1, since 00:05:45

Se4/2, since 00:05:45

Se4/3, since 00:05:45

Se4/5, since 00:05:45

Se4/6, since 00:05:45

Se4/7, since 00:05:45

No inactive multilink interfaces

(Now let’s see the configuration of layer 2 Etherchannel)

 

  • configure the four physical links range fa 0/1-4 from switch 1
  • configure the four physical links range fa0/11-14 from switch 2
  • configure pagp which is cisco proprietary protocol.

switch-l2-(config)#interface range ethernet 0/0-3
switch-l2-(config-if-range)#channel-protocol pagp
switch-l2-(config-if-range)#channel-group 11 mode desirable
Creating a port-channel interface Port-channel 11
switch-l2-(config-if-range)#end

switch-l2-(config)#interface port-channel 11
switch-l2-(config-if)#switchport trunk encapsulation dot1q
switch-l2-(config-if)#switchport mode trunk
switch-l2-(config-if)#end

IOU2(config)#interface range ethernet 0/0-3

IOU2(config-if-range)#channel-protocol pagp

IOU2(config-if-range)#channel-group 11 mode desirable

Creating a port-channel interface Port-channel 11

IOU2(config-if-range)#exit

switch-l2-#show etherchannel port-channel
Channel-group listing:
———————-
Group: 11
———-
Port-channels in the group:
—————————
Port-channel: Po11
————
Age of the Port-channel   = 0d:00h:03m:29s
Logical slot/port   = 16/0          Number of ports = 4
GC                  = 0x000B0001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   PAgP
Port security       = Disabled
Ports in the Port-channel:
Index   Load   Port     EC state        No of bits
——+——+——+——————+———–
0     00     Et0/0    Desirable-Sl       0
0     00     Et0/1    Desirable-Sl       0
0     00     Et0/2    Desirable-Sl       0
0     00     Et0/3    Desirable-Sl       0
Time since last port bundled:    0d:00h:00m:34s    Et0/2
Time since last port Un-bundled: 0d:00h:00m:40s    Et0/3

switch-l2-#show etherchannel summary
Flags:  D – down        P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3      S – Layer2
U – in use      f – failed to allocate aggregator
M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
——+————-+———–+———————————————–
11     Po11(SU)        PAgP      Et0/0(P)    Et0/1(P)    Et0/2(P)
Et0/3(P)
switch-l2-#show etherchannel
Channel-group listing:
———————-
Group: 11
———-
Group state = L2
Ports: 4   Maxports = 4
Port-channels: 1 Max Port-channels = 1
Protocol:   PAgP
Minimum Links: 0

switch-l2-#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    32769
Address     aabb.cc00.0100
This bridge is the root
Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     aabb.cc00.0100
Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  300 sec
Interface           Role Sts Cost      Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr
Et1/2               Desg FWD 100       128.7    Shr
Et1/3               Desg FWD 100       128.8    Shr
Et2/0               Desg FWD 100       128.9    Shr
Et2/1               Desg FWD 100       128.10   Shr
Et2/2               Desg FWD 100       128.11   Shr
Et2/3               Desg FWD 100       128.12   Shr
Et3/0               Desg FWD 100       128.13   Shr
Et3/1               Desg FWD 100       128.14   Shr
Et3/2               Desg FWD 100       128.15   Shr
Et3/3               Desg FWD 100       128.16   Shr
Po11                Desg FWD 41        128.65   Shr

switch-l2-#show interface trunk
Port        Mode             Encapsulation  Status        Native vlan
Po11        auto             n-802.1q       trunking      1
Port        Vlans allowed on trunk
Po11        1-4094

(let’s see the configuration of layer 3 EtherChannel port-channel

 

  • configure portchannel
  • verify port-channel
  • configure routing EIGRP
  • configure IP on VLAN 1
  • verify with show commands.

Layer-3-switch-(config)#interface range ethernet 0/0-3
Layer-3-switch-(config-if-range)#no switchport
Layer-3-switch-(config-if-range)#channel-group 10 mode on
Creating a port-channel interface Port-channel 10
Layer-3-switch-(config-if-range)#exit

Layer-3-switch-(config)#interface port-channel 10
Layer-3-switch-(config-if)#ip address 192.168.10.1 255.255.255.0
Layer-3-switch-(config-if)#no shutdown
Layer-3-switch-(config-if)#exit

Layer-3-switch-(config)#interface ethernet 1/0
Layer-3-switch-(config-if)#switchport
Layer-3-switch-(config-if)#switchport mode access
Layer-3-switch-(config-if)#switchport access vlan 1
Layer-3-switch-(config-if)#exit

Layer-3-switch-(config)#interface vlan 1
Layer-3-switch-(config-if)#ip address 10.1.1.1 255.0.0.0
Layer-3-switch-(config-if)#no shutdown
Layer-3-switch-(config-if)#exit

Layer-3-switch-(config)#ip routing

Layer-3-switch-(config)#router eigrp 100
Layer-3-switch-(config-router)#network 10.0.0.0
Layer-3-switch-(config-router)#network 192.168.10.0
Layer-3-switch-(config-router)#no auto-summary
Layer-3-switch-(config-router)#exit

Layer-3-switch-(config)#interface range ethernet 0/0-3

Layer-3-switch-(config-if-range)#no switchport

Layer-3-switch-(config-if-range)#channel-group 10 mode on

Creating a port-channel interface Port-channel 10

Layer-3-switch-(config-if-range)#exit

Layer-3-switch-(config)#interface port-channel 10

Layer-3-switch-(config-if)#ip address 192.168.10.2 255.255.255.0

Layer-3-switch-(config-if)#no shutdown

Layer-3-switch-(config-if)#exit

Layer-3-switch-(config)#interface ethernet 1/0

Layer-3-switch-(config-if)#switchport

Layer-3-switch-(config-if)#switchport mode access

Layer-3-switch-(config-if)#switchport access vlan 1

Layer-3-switch-(config-if)#exit

Layer-3-switch-(config)#interface vlan 1

Layer-3-switch-(config-if)#ip address 20.1.1.1 255.0.0.0

Layer-3-switch-(config-if)#no shutdown

Layer-3-switch-(config-if)#exit

Layer-3-switch-(config)#ip routing

Layer-3-switch-(config)#router eigrp 100

Layer-3-switch-(config-router)#network 20.0.0.0

Layer-3-switch-(config-router)#network 192.168.10.0

Layer-3-switch-(config-router)#no auto-summary

Layer-3-switch-(config-router)#exit

Layer-3-switch-#show etherchannel

Channel-group listing:

———————-

Group: 10

———-

Group state = L3

Ports: 4   Maxports = 4

Port-channels: 1 Max Port-channels = 1

Protocol:    –

Minimum Links: 0

Layer-3-switch-#show etherchannel port-channel

Channel-group listing:

———————-

Group: 10

———-

Port-channels in the group:

—————————

Port-channel: Po10

————

Age of the Port-channel   = 0d:00h:02m:26s

Logical slot/port   = 16/0          Number of ports = 4

GC                  = 0x00000000      HotStandBy port = null

Passive port list   = Et0/0 Et0/1 Et0/2 Et0/3

Port state          = Port-channel L3-Ag Ag-Inuse

Protocol            =    –

Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits

——+——+——+——————+———–

0     00     Et0/0    On                 0

0     00     Et0/1    On                 0

0     00     Et0/2    On                 0

0     00     Et0/3    On                 0

Time since last port bundled:    0d:00h:02m:26s    Et0/3

\

Layer-3-switch-#show etherchannel protocol

Channel-group listing:

———————-

Group: 10

———-

Protocol:   –  (Mode ON)

Layer-3-switch-#show etherchannel summary

Flags:  D – down        P – bundled in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3      S – Layer2

U – in use      f – failed to allocate aggregator

M – not in use, minimum links not met

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

——+————-+———–+———————————————–

10     Po10(RU)         –        Et0/0(P)    Et0/1(P)    Et0/2(P)

Et0/3(P)

Updated on March 21, 2025
Table of contents

Frequently Asked Questions

Ebooks FAQ

  • May I share my eBooks with others?

    You can share Ebooks with anyone

  • What is an eBook?
    1. eBooks are digital, downloadable versions of books. In most cases, they look exactly like the print versions with the same graphs, charts, and illustrations.
    2. You can download and read eBooks on your desktop, laptop, and mobile devices with the free Reader application.
  • Do I need special software or hardware to read eBooks?

    All you need is your PC, laptop or hand held device and the free Reader software. We offer eBooks in three different formats: PDF download, EPUB download and Online Reader.  Our Online Reader requires no software other than an internet browser. For downloading, we will provide you with a link to download the appropriate Reader software free of charge when you make a our member. 

  • I have a questions

    If you have any questions including file download or Ebooks name errors, copyright etc, please contact us

  • How to downloan ebooks?

    Immediately. Once you complete you register a member account first and download it free 

  • what’s Ebooks files format ?

    our eBooks as EPUB, CHM and PDF files. 

    To read EPUB files, you can download the latest version of the free Adobe Digital Editions here.

    To read PDF files, you can download the latest version of the free Adobe Acrobat Reader here. 

    Notes:some files need unzip,you can read it

  • I can’t find the some ebooks?

    If you need any Ebooks, please contact us.